+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Airman Basic
    Join Date
    Apr 2011
    Posts
    8

    Setting the time

    I have found with my 126 vintage heritage that at times it takes the minute hand a minute to catch up. That is, if I set it at 12:00:00, after a minute with the second properly tracking the time, the minute hand hasn't moved. Then it begins moving and so it reads a minute slow. At other times, the minute hand starts right up. Is there a secret here on how to set the time or do I need to have it checked by my AD.

    Thanks!

  2. #2
    Airman Basic redgloves's Avatar
    Join Date
    Jun 2011
    Posts
    6
    I have the same problem with my BR01-94. Sometimes it takes 1minute for the minute hand to 'take-up', and, more annoyingly, 90 seconds!

    I am adamant that I want the second hand and minute hands synchronised as well as possible, so this odd behaviour is annoying - is there a 'technique' for making the minute hand move as soon as you push the crown in?

    Any help or similar experiences would be interesting to hear...
    Regards
    Mike

  3. #3
    Bell&Ross Gudzyy's Avatar
    Join Date
    Apr 2009
    Posts
    1,282
    Strange! never had this problem with a any of my watches... If they are still under warranty, maybe you should send them to have it checked/corrected
    Gudzyy

    BR01 92 | 93 | 94 | 97 | Airborne --- BR-X1
    Pilot Sapphire Chasse Embarquee et 10th Anniversary
    Exclusive trio R.A.I.D
    (gone : 01-92SS Black, 02-94SS, 01-92Radar, Officer 123 silver, 03-94 héritage,0196 white,BR02CF)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts